Damn Small Linux (DSL) Forums

Damn Small Linux => Other Help Topics => Topic started by: solder4fun on May 20, 2013, 03:01:55 PM



Title: text cursor dissapearing in text boxes, using DSL-4.4.10, please help
Post by: solder4fun on May 20, 2013, 03:01:55 PM
This problem was not observed while running from the liveCD, only after I installed to HD.

Problem:
When I use text input boxes, like the search box in google or ebay: if I click in the text box, the cursor dissapears, and typing won't show any characters in the text box. This happens in other programs not just firefox, which leads me to believe it is happening at the OS level.

This was first observed while trying to write sketches in Processing 1.5, that is if I open a new sketch, the cursor is visible and I can start writing without any problems, but as soon as I click within the editor window (text area, like click to a different line or try to highlight text to copy) the cursor disappears and I am unable to type in the editor window.
 

What I've done so far:
Initially I booted a liveCD of DSL-4.4.10 to test with, then downloaded Processing 1.5(programming language), wrote some simple sketches and made sure DSL could run them, which it did, so the next step was to make a permanent installation:

I then used a 4GB CF with an IDE adapter, installed DSL to the CF as if it was a regular hard drive per the HD install instructions (installed smoothly, just followed the instructions), downloaded Processing 1.5, extracted and started to use like normal, its when I started editing text that the cursor problem began to show up, not just in Processing, but also in Firefox, which is why I believe it is not program specific.

Any help with this problem will be greatly appreciated, since this is the only problem I've run into so far.









Title: Re: text cursor dissapearing in text boxes, using DSL-4.4.10, please help
Post by: CNK on May 21, 2013, 07:01:53 AM
I'm afraid I haven't seen your problem before, but I can say that the Ebay search bar doesn't work at the best of times with the old Firefox that comes with DSL. I search by modifying the text in the URL.

The other things should work though.

Presumably you compiled "Processing", so try "make uninstall" and if the problem goes away, play with the configure options to see if you can disable what's causing the problem for the next install. Or if uninstalling doesn't work, do the same and just keep re-installing DSL, it's usually fairly quick on modern PCs.


Title: Re: text cursor dissapearing in text boxes, using DSL-4.4.10, please help
Post by: solder4fun on May 22, 2013, 01:10:04 AM
Problem fixed........kinda of.

All I did was switch to the Fluxbox Window Manager.......now I am able to place the cursor where ever in Processing and can manipulate text as needed.

Thank you for the reply and suggestions.




Powered by SMF 1.1.20 | SMF © 2013, Simple Machines