Damn Small Linux (DSL) Forums

Damn Small Linux => Other Help Topics => Topic started by: CNK on June 16, 2013, 03:02:52 AM

Title: Start program in terminal in its own directory from DSL menu link
Post by: CNK on June 16, 2013, 03:02:52 AM
I've had this problem for a while, but I've finally admitted defeat at trying to solve it myself.

I have a Java program (replicatorG) that will only launch from a terminal in its own directory. I am trying to launch it from the DSL menu using aterm, but so far nothing has worked.

Here is a list of what I have tried, not in order:
  • Launching it using the aterm option "-e" followed by either replicatorg (directory specified in $PATH) or the full path name. Window appears for a moment and then closes with an error.
  • Launching it without aterm by enterring "replicatorg" or the full path as the program in .jwmrc. Nothing happens when clicked.
  • Creating a two-line script that first "cd"s to replicatorg's directory, then runs replicatorg. Thereafter entering this into .jwmrc so that it is executed by aterm. I since learnt that scripts can't change their directory, so this did the same as the first attempt.
  • Placing an "alias" command in .bashrc that causes the directory to be changed to that of replicatorg with the command "repgdir", then using "repgdir" where the "cd" command was in the script from above. This didn't change a thing, seems Bash is too smart for these sort of tricks.
  • Give up. Simply open a terminal and type "replicatorg" manually to start it each time. This works, but severely harms my pride.

I think I read once online about ways to do this with other distros, but it was going to be too much trouble to modify DSL to use the same methods.

Well any help will be greatly appreciated. If I ever discover an anwser to my problem, I'll post it here.

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines