Damn Small Linux (DSL) Forums

MyDSL Extensions => Net => Topic started by: carlo on November 04, 2013, 05:10:36 PM



Title: alt-gr-keys in firefox 2.0
Post by: carlo on November 04, 2013, 05:10:36 PM
 Hello

I'm using a hard drive install, latest stable version of dsl. I have a be-latin1 keyboard setting, and when I am on the internet with a Firefox-like browser, my @ key (and all other alt gr+keys) wont work. If I just have run xsetup.sh it "does", but after reboot no more. Dillo is the only browser which print it, but I tried to login my yahoo mail with Dillo (I need @ to login), than there is a problem with cookies (that version of Dillo is to old I think, because in the cookiesrc, cookies are enabled with "#default exept". Can anyone tell me what I can do to have another shortcut for @. I allready tried to put echo @ in the jwmkeysrc but it failed (it than writes it into the text part of the system, that you can see with "ctrl+alt+f1").
 
       Thanks


Title: Re: alt-gr-keys in firefox 2.0
Post by: CNK on November 05, 2013, 12:38:34 AM
So the problem is fixed when you set the keyboard language in xsetup?

In that case, you might want to try adding the "lang=<language>" command to the "kernel" line for DSL in "/boot/grub/menu.lst", as described here (http://www.damnsmalllinux.org/wiki/cheat_codes.html).


Title: Re: alt-gr-keys in firefox 2.0
Post by: carlo on November 05, 2013, 04:44:39 AM
I have added "dsl lang=be" to the menu.lst and ... it works !

Thanks


Title: Re: alt-gr-keys in firefox 2.0
Post by: Grissel on February 01, 2018, 07:30:44 AM
Guaranteed to provide information to that already received clarification of the content correctly.


Powered by SMF 1.1.20 | SMF © 2013, Simple Machines