Damn Small Linux (DSL) Forums

Damn Small Linux => Laptops => Topic started by: Benny on May 18, 2014, 09:58:12 PM

Title: How to find what's happening if DSL gives me "read error...-problem reading...
Post by: Benny on May 18, 2014, 09:58:12 PM
...cylinder 0 - expected 18432, read -1"?

I've seen the led of the drive indicating activity for more than 30 mins.. What I need to know is if it can be killed even though the process is started from emelfm? If, for being able to kill it I've to start it from the console, it might be useful to have a short list of commands for mounting, unmounting and running files (apps) from there - installing, etc.).

Thanks for any help on this!

Title: Re: How to find what's happening if DSL gives me "read error...-problem reading.
Post by: CNK on May 19, 2014, 09:21:11 PM
Have you tried reading the same partition of the drive from other Linux Distros? If it doesn't work with them, it might be a problem with the file system (run fsck) or the HDD itself.

I don't know of any better way to kill a process started with Emelfm than killing Emelfm itself. There's no command in the keyboard shortcuts list.

I don't fully understand why you want a list of terminal commands. in any case, you mount with the command "mount", unmount with the command "umount" and install MyDSL extensions with the command "MyDSL <extension name>". Look at mount --help for how to use the commands fully, but basically just put the path to the mount point after the command, eg. "mount /mnt/hda3" to mount partition hda3. If it says the entry isn't in fstab, that means the system hasn't automatically set up a partition to use with that mount point.

Title: Re: How to find what's happening if DSL gives me "read error...-problem reading.
Post by: Benny on May 20, 2014, 02:37:45 AM
Thanks for replying, CNK!

The reason for asking of those commands is that starting a process from the terminal, if it's not finishing, is easier to kill it at the spot. BTW, those folders (etc/fstab & etc/mtab) don't exist, at least the terminal gave me that message.

Without a floppy disk in, I tried to mount the drive (fd0) from emelfm (/ramdisk/home/dsl) but there was not an option for it. With a disk in, the same.

For some reason today I can't use the drive...?

I don't have for the moment another system for trying to read the diskette.

The way of 'killing' a process started from emelfm I suspected was killing emelfm itself; even though I think the other day the led at the driver never went off.

Thanks for any ideas around this!

Title: Re: How to find what's happening if DSL gives me "read error...-problem reading.
Post by: CNK on May 20, 2014, 10:39:00 PM
Hmm, strange. Perhaps try creating the two files (as root) and checking that the "nofstab" option isn't in your startup commands on the "kernel" line of /boot/grub/menu.lst, then restart and see if things work.

You can create fstab entries manually (search for guides online, there are plenty), but it probably wouldn't be practical if your machine has USB. It could also be that DSL is having trouble reading the spot on the disk with fstab (though I don't know why it wouldn't show up in a directory listing), try running fsck on the DSL partition.

You could look at the dmesg log (can be viewed in the "System Stats" window (in the DSL menu "System>System Stats")) to see that DSL is detecting the drives at all, they should be there with a short description (though the floppy drive will just say it's 1.44MB (unless it's an old DD type)).

For a short-term fix, you can tell Linux what to mount where directly with the "mount /dev/<device> <mountpoint>". For example your floppy drive could be mounted using "mount /dev/fd0 /mnt/auto/floppy". Or was that what hung the terminal?

Title: Re: How to find what's happening if DSL gives me "read error...-problem reading.
Post by: Benny on June 08, 2014, 04:52:55 PM
Thanks for replying, CNK!

I checked with the included app within DSL that you mentioned and yes, there's an entry that states "fd0 is a 1.44MB drive"; so, recognition isn't an issue.

I'm planning now to use a floppy disk for saving a backup of my Bon Echo bookmarks because a few weeks ago something strange happenned and I lost ALL my bookmarks. Even though I've other backups at the cloud it has been IMPOSSIBLE to retrieve any of them because all the necessary buttons AREN'T clickable in any of them (Google-Drive, Dropbox, 4Shared and Skydrive).

BTW, after loosing the bookmarks I started to experiment a little bit with downloading some extensions and I encountered a little problem with the instructions at the 'Wiki'? If I'm not wrong, for the Menu corresponding item to appear I've to click at the topmost button at the emefm app, but the name used at the wiki doesn't appear at my app, it just says: Add2Filetool.
Obviously, the first time I tried it it worked but it wasn't persistent. After I rebooted the system the extensions appear at the location where I put them but not the icons (entries) at the MyDSL menu.

PS. --Something that I've encountered recently that don't know how to solve is my default password in DSL; I don't remember if in the past I've changed it or not or what the default was; the system has said to me several times already that "I don't have permission to do this or that"... Can you help on this?

Thanks for any info on these subjects!

Title: Re: How to find what's happening if DSL gives me "read error...-problem reading.
Post by: CNK on July 13, 2014, 12:43:45 AM
The permissions errors are because some tasks must be done by the "root" user. Use the root terminal to execute commands (can be found in the Xshells menu of the DSL menu), or "emelfm as Super-User" which can be found in "Apps>Tools>Emelfm File Manager". You can also execute commands as root from a normal user terminal by preceding them with the "sudo" command, eg. "sudo nano /etc/fstab".

Extensions can be loaded by double clicking on them in Emelfm, or using the command "mydsl-load <extension name>". On a HDD install, ".dsl" and ".tar.gz" extensions will be permaently installed on the system while ".uci" and ".unc"  types will be gone at the next reboot. In a Frugal install, nothing stays. You can have them auto-load by placing them in a "mydsl" folder on a partition you specify in the menu.lst kernel line (see the "cheatcodes" page of the Wiki), or putting "mydsl-load" commands for each extension in the "/opt/bootlocal" file.

Did you get the floppy drive working, if you were only trying one disk it could have just gone bad.

Title: How to find whats happening if DSL gives me "read error problem reading
Post by: Rapstultpap on August 16, 2017, 05:08:38 PM
ya i have read alot of about the powerpads, the only downside to them is that you should take your battary pack out when using it as it will try and charge the battary and run your computer at the same time which will decrease battary power in the powerpad and you cant really tell how much is left in the powerpad yes there is a little strip of leds, but for that kinda money i would think putting a usb cable on it to report the remaining battery level would have been to hard

 Also, I want to share with you the best and free substitute for Carfax  http://vehhistory.com . You can check vin reports regarding any vehicle here.

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines