Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
Did you miss your activation email?
February 19, 2017, 04:40:28 PM

Login with username, password and session length
News
The new DSL forums are now open.
Stats
301276 Posts in 294229 Topics by 295 Members
Latest Member: lytupmdeta
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  Recent Posts
Pages: 1 2 3 [4] 5 6 ... 10
 31 
 on: December 24, 2016, 10:12:34 PM 
Started by aesvry - Last post by CNK
Yes, put the boot commands you used after "dsl" before, at the end of the command line for that menu option in "/boot/grub/menu.lst". Also remove the "vga=788" command from that line (in my menu.lst it's vga=791 for fb1024x768, but no matter).

With this done, the line should look like:
'kernel /boot/linux24 root=/dev/hda2 quiet noacpi noapm nodma noscsi frugal xmodule=fbdev fb1024x768 lowram'

Some of the other options could probably be played with as well to increase performance and features, but I'll leave you to play around with that with reference to the wiki page  (http://damnsmalllinux.org/wiki/cheat_codes.html), if desired.

 32 
 on: December 24, 2016, 12:35:45 PM 
Started by Borzalex - Last post by Borzalex
Well, I didn't mount anything on sda1 before. And when I enter command lsusb or lsusb -v nothing happens. I do remember that USB worked fine earlyer when there was Windows XP installed... Maybe i need to install additional drivers for my motherboard?

 33 
 on: December 24, 2016, 03:25:15 AM 
Started by aesvry - Last post by aesvry
ran into another small issue Sad most likely the fix is just as simple as the last but I'm just not sure of what to do.

So now I have DSL installed on the hard drive and need to boot without the CD to complete the installation. When the computer starts and I get to GRUB it gives me 4 options

DSL
DSL fb800x600
DSL fb1024x768
DSL fb1280x1024

When I choose DSL fb1024x768 and it goes through it's startup it starts in xvesa which goes right back to where I started with the same problem. The screen moves too quickly for me to type in any commands to change it though I caught a glimpse of it giving me an instruction on what to do if I wanted to change the display.

So I rebooted and went back into grub and to edit for DSL fb1024x768 and it is: 'kernel /boot/linux24 root=/dev/hda2 quiet vga=788 noacpi noapm nodma noscsi frugal'

Would I be able to correct the problem here? And if so what would be the correct way to type out the command?

Thanks again for the help. Smiley

 34 
 on: December 23, 2016, 10:39:52 PM 
Started by aesvry - Last post by aesvry
Using "dsl xmodule=fbdev fb1024x768 lowram" worked perfectly! Thank you I really appreciate your help. Smiley

 35 
 on: December 23, 2016, 08:58:42 PM 
Started by Borzalex - Last post by CNK
"sudo mount /dev/sda1 /mnt/usbflash" should be enough, the error indicates that the USB drive is not being detected, or perhaps is being assigned to another device ID due to the (mis)detection of some other unreadable drive as sda1.

Perhaps you've already tried mounting outher /dev/sd(x)1 in other locations. If the USB drive is being detected at all, it should show up in the list of use devices presented when you execute the command "lsusb -v". If not, you may have a USB driver problem.

Also note that DSL usually tries to automatically add fstab entries linking /dev/sd(xx) entries to /mnt/sd(xx), such that "mount /dev/sda1" would by default mount it at /mnt/sda1. Your more complete command should work regardless of this though.

 36 
 on: December 23, 2016, 08:39:16 PM 
Started by aesvry - Last post by CNK
Try entering the "fb1024x768" command (on its own, without "dsl" first) at the boot command prompt and see if that works. If you still need to use the "lowram" command, do it like this: "dsl xmodule=fbdev fb1024x768 lowram". Fo details see the wiki page on boot time commands  (http://damnsmalllinux.org/wiki/cheat_codes.html).

If it still doesn't work, you can try the instructions gor setting specific vga modes and detecting non-standard ones, also on the wiki  (http://damnsmalllinux.org/wiki/vga_xxx.html).
EDIT: Looking into the details of the laptop model in general, it does seem quite possible that it would use non-standard vga modes in order to accomodate the unusually large display.

 37 
 on: December 23, 2016, 01:26:59 AM 
Started by aesvry - Last post by aesvry
I've been trying to get an old Gateway 2000 Destination PC back up and running recently. It has a 200MHz Pentium Processor with 32 MB RAM.

I burned a disc of DSL 4.0 and booted the computer from that, I found that before anything started up I had to go into the DSL boot options and choose 'lowram' otherwise after it was done loading everything up and got to the section for the Xvesa settings I would just get a blank screen. So when I finally got to the settings, no matter what I chose I would get the same result of a corrupted screen image. Just a black screen with a small green corrupted image at the very top. I decided to test it out on another installation disc I had for Wary 5.5. This had the option of using xorg instead of xvesa, when I chose xorg it probed the video hardware in the computer to see what settings would work best. It came back with a rang of options but recommended 1024x768x16 as what would work best for the video card and monitor. I tested this out and while it could barely load because Wary is too much for the system to handle everything seemed to be just fine with the display. So I go back to DSL and follow the same steps I had before and put in those settings of 1024x768x16 and same result. I was wondering if anyone had some knowledge on what I could do to fix this problem? Any help would be appreciated, thanks!  Smiley (Attached is an image of the screen issue)

 38 
 on: December 22, 2016, 06:28:25 PM 
Started by Borzalex - Last post by Borzalex
Hello! I have DSL 4.11 rc2 installed on my HDD. When I try to mount the USB stick with a command
sudo mount -t vfat /dev/sda1 /mnt/usbflash -o iocharset=utf8,codepage=866,rw
I get the following error:
/dev/sda1 is not a valid block device
Is there any other way to mount the USB stick?..



 39 
 on: November 29, 2016, 09:25:45 PM 
Started by Astrosynthesist - Last post by CNK
The 1600x1200 resolution is noted on this page though (http://www.faqs.org/docs/Linux-HOWTO/Framebuffer-HOWTO.html#ss5.3).

perhaps check that the values you entered line up with those there (converted to decimal).

There is the option of using specific video grivers instead of the frame buffer in DSL, but I don't think the drivers for your video chipset are available. Might be worth looking into, I don't have the time to double check.


 40 
 on: November 29, 2016, 09:12:09 PM 
Started by Astrosynthesist - Last post by CNK
These remastering guides are a bit old, but might still work:
http://schooner.uwaterloo.ca/twiki/bin/view/Linux/RemasteringGuide
http://damnsmalllinux.org/static/act-ST/f-12/t-7177.html

However it seems you should be able to set DSL to restore your modified /etc/pcmcia/config.opts file  (http://damnsmalllinux.org/wiki/persistence.html) automatically on each boot. Then, if cardmgr is already started by the time the configuration file is replaced, put "killall -HUP cardmgr" in the /opt/bootlocal.sh file to restart it.

EDIT: I forgot about the fact the laptop actually hangs when the wrong PCMCIA command is sent. Perhaps try using the "nopcmcia" boot command and start cardmgr manually in /opt/bootlocal.sh after the right config files have loaded.

Pages: 1 2 3 [4] 5 6 ... 10
Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Mercury design by Bloc