Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
December 05, 2023, 02:52:19 PM

Login with username, password and session length
The new DSL forums are now open.
11609 Posts in 311 Topics by 291 Members
Latest Member: mik3ca
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  Damn Small Linux
| |-+  Other Help Topics
| | |-+  Virtualbox Guest Additions
« previous next »
Pages: [1] Print
Author Topic: Virtualbox Guest Additions  (Read 11102 times)
Posts: 4

View Profile Email
« on: November 03, 2014, 08:27:46 PM »


I have a couple of DSL installs on VirtualBox (https://www.virtualbox.org/) so that I can try stuff out on it whilst doing other stuff. Love the distro. So many cool things in such a small space.

Virtual box allows you to mount a "shared folder" from the host OS (Windows 7 in my case), so that you can access them. It also allows you to copy/paste, drag/drop, between the host and guest OS (DSL)... however you need to install guest additions to get access to these handy features. I have seen from googles that quite a few people seem to have installed DSL on virtualbox, and some seem to have got the guest additions working but I am stuck. Any help appreciated. Here's what I got so far:

HD install of DSL 4.4.10 onto VirtualBox 4.3.16 as 32-bit Linux 2.4 (have also tried with Debian 32-bit setting)
- start up VM and attempt to set up shared folders (VirturalBox -> Devices -> Share Folder Settings)
- Error dialog appears "The VirtualBox Guest Additions do not appear to be available on this virtual machine, and shared folders cannot be used without them. To use shared folders inside the virtual machine, please install the Guest Additions....
- load the guest additions CD into the virtual CD drive (VirtualBox -> Devices -> Insert Guest Additions CD image
- mount it (DSL->Mount->click once to get cdrom -> click to mount (box goes green "mounted")
- DSL cd /mnt/cdrom
- sudo bash ./VBoxLinuxAdditions.run
- see error messages about no cc
- go to /usr/bin and sym link tcc to cc
- retry - realise it needs gcc and make
- go to MyDSL - can't get downloads
- go to Apps/Tools/MyDslMirrors and select a suitable mirror
- retry system- > gcc with libs install in MyDSL - success :-)
- re link cc so that it points to gcc
- retry sudo bash ./VBoxLinuxAdditions.run - fails again, need kernel headers
- back to MyDSL - install system->kernel sources
- retry sudo bash ./VBoxLinuxAdditions.run - fails again, kernel headers still not found
- check /usr/src and discover the kernel source is version 2.4.26 vs actual kernel version is 2.4.31
- add a symlink ln -s /usr/src/linux-2.4.26  ln -s /usr/src/linux-2.4.31
- retry sudo bash ./VBoxLinuxAdditions.run - fails again with compiler errors

At this point I would love to copy and paste the errors or copy off the error log to a shared folder, but of course I can't do either until I get guest additions working! So here is a hand typed summary of the first error.

The first error is an undefined type:
In file included from  ....../include/iprt/types.h
In file included from  ....../linux/the-linux-kernel.h
In file included from  VBoxGuest-linux.c
/lib/modules/2.4.31/build/include/linux/types.h:21: error: parse error before "dev_t"
/lib/modules/2.4.31/build/include/linux/types.h:21: warning: data definition has no type of storage class

Does anybody know how to proceed from this point? I have tried installing one of the existing VirtualBox DSL images in the hope that they already set up guest additions, but sadly not :-(

Any help appreciated.


Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Mercury design by Bloc