Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
Did you miss your activation email?
June 29, 2017, 02:08:08 PM

Login with username, password and session length
News
The new DSL forums are now open.
Stats
302231 Posts in 295164 Topics by 311 Members
Latest Member: AntjeBzd76
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  Damn Small Linux
| |-+  HD Install
| | |-+  Installed, but Boot Loader Problem
« previous next »
Pages: [1] Print
Author Topic: Installed, but Boot Loader Problem  (Read 7692 times)
borgward1
Newbie
*
Posts: 2


View Profile
« on: June 17, 2015, 04:40:29 PM »

I started DSL install.Selected multiple users.  Got message "installed" Next came something about boot loader. I clicked on that, but nothing is happening. I don't think the process is finished. CD has not ejected as I would expect.

Dell Dimension 4550. 1GB RAM, 30GB HDD. Had LinuxMint 17 Mate installed with 2 partitions, hda1, and hda2. Installed DSL to hda1. What Am I supposed to do now? What about updates? Security? I got question about using ext2 or ext3 file system, and that ext 2 was for slower systems. Well what catagory does the 4550 with P4 2.4 Ghz with 1 GB RAM fit into? I selected ext3. I kept getting security warning for every site I went to when running Firefox from the Live CD. Since The live is running from root, I can understand that, but is very annoying. Will I have that behavior after I am running from the HDD? I plan to use AdBlock Plus and NoScript then. I just planned on having 2 partitions, one for / and another for /home. any advice for partitioning? hda1 is 4 + GB and hda2 takes up the rest of the drive .
Logged
Diogenes
Newbie
*
Posts: 4


View Profile
« Reply #1 on: June 17, 2015, 05:12:51 PM »

http://www.damnsmalllinux.org/wiki/installing_grub.html#Installing_GRUB
t should have given you a choice between grub and lilo,  both boot loaders. Grub is better documented but either should work fine. The link above should help you; basically, if a boot loader hasn't installed,  burn a grub live cd from superggrubdisk.org,  and install as per the first link.

Updates are far and few between,  and while apt-get update is possible,  it will most definitely break your system.  DSL's focus is entirely size,  and squeezing as much day to day productivity as you can out of any hardware.  Updates and security take a distant back seat.

I would expect that behaviour to not happen once installed,  but if it does which it may I will gladly help you then.

Do you still have mint installed? In either regard,  4gb is plenty for DSL, though depending on what applications you install I would go no lower than 0.5gb,  the rest for /home. Honestly though, leave hda1 as is and use hda2 as home/storage.
Logged
Lizavials
Newbie
*
Posts: 9

117323747 rkoliv@yandex.com Lizavials Lizavials
View Profile
« Reply #2 on: January 24, 2017, 06:50:07 AM »

I installed Nas4free several years ago.  I left it unplugged for about a year while in storage.  I tried starting the system up and it told me I had a boot sum error.  I remember the last time I had that i had to replace the on board battery.  I did that but now Im getting a disk boot failure I then thought it was a flashdrive that went bad so I went and bought a new drive and downloaded the software onto the drive.  Still giving me the same error.  Any thoughts?
Logged

Я генерирую добро. (http://www.vixino.autoprichal.ru/)
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Mercury design by Bloc