Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 13, 2017, 08:32:31 PM

Login with username, password and session length
News
The new DSL forums are now open.
Stats
302366 Posts in 294248 Topics by 310 Members
Latest Member: ThomasViatt
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  MyDSL Extensions
| |-+  Extension Development
| | |-+  Alsa configured at boot in frugal install
« previous next »
Pages: [1] Print
Author Topic: Alsa configured at boot in frugal install  (Read 9300 times)
carlo
Newbie
*
Posts: 21


View Profile
« on: December 30, 2014, 03:58:02 PM »

Hello

I'm running DSL latest stable release, frugal installed (grub).

I'm trying to have alsa "configured" at boot.

So I have the alsa boot option enabled before loading alsa4dslv2.dsl (in boot). I have also put
Quote
"proc/, etc/modutils/sound, ramdis/etck/var/tmp/alsaconf.cards, etc/modprobe.conf, etc/asound.state, opt/alsa"
into the filetool.list, plus
Quote
"/init.d/alsasound start" and "/usr/sbin/alsactl restore"
into the bootlocal.sh.   
Still I have to do the whole alsaconf stuff before having sound.               

My hardware is pci intel8x0.

At this moment I can have a part of it configured by doing first
Quote
"/opt/alsa/alsasetup (just the command, without the other staps)" than "modprobe snd-intel8x0" plus "alsactl restore"
.
With this I can play wav files in xmms if configured with alsa (not oss, as it is by default).
Soundtracker on the contrary doesn't peep.                                     
Anyone?

Thanks
Logged
carlo
Newbie
*
Posts: 21


View Profile
« Reply #1 on: January 07, 2015, 09:54:16 AM »

Hello again

I have already found the solution.

So I have loaded the "alsa4dslv2.dsl" at bootup and have set the alsa boot option.
I know this extension works. This means, I have already used it and have a "/etc/asound.state" file generated by "
Quote
sudo alsactl store
".
Instead of making a backup of the files like mentioned above I have discovered a way to ad files to a .dsl extension.
First of all, you rename alsa4dslv2.dsl in alsa4dslv2.tar.gz.
Than do
Quote
gzip -d alsa4dslv2.tar.gz
and you can ad files to it by doing "
Quote
tar -rf alsa4dslv2.tar file1 file2
".
Then do
Quote
"gzip alsa4dslv2.tar"
and, rename it back to alsa4dslv2.dsl.
To my surprise it works. For one or another reason opening and repacking it makes it useless.
So I added the files /etc/asound.state and /etc/modutils/sound.

At this point there are still 5 commands to execute. I have put them all in a file that I have made executable. To do that, I Did "
Quote
sudo chmod 777 file
".
You can put that file in your home directory (eg: /home/dsl/.alsastart) and than start it at bootup as a command in "/home/dsl/.xinitrc" or "/opt/bootlocal.sh".

The 5 commands are:
Quote
1)sudo /opt/alsa/snddevices 2) sudo depmod -a 3) sudo modprobe snd-intel8x0 (=driver for your sounddevice) 4) sudo update-modules 5) sudo alsactl restore.
     
If it complains about unresolved characters in a certain driver, normally you can continue.

 Thanks.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Mercury design by Bloc