Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
Did you miss your activation email?
November 12, 2019, 05:38:33 AM

Login with username, password and session length
News
The new DSL forums are now open.
Stats
11410 Posts in 415 Topics by 653 Members
Latest Member: MeriLudowi
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  Damn Small Linux
| |-+  User Feedback
| | |-+  How to setup an USB 2.0 Ethernet adapter?
« previous next »
Pages: [1] Print
Author Topic: How to setup an USB 2.0 Ethernet adapter?  (Read 36981 times)
csanyipal
Newbie
*
Posts: 2

Mr. Paul


View Profile Email
« on: December 22, 2018, 08:26:54 AM »

Hi,

I just installed (Frugal install) DSL on my very old Toshiba Satellite 2540CDS laptop.
Some specs:
333MHz AMD K6-2 processor,
HDD (2.5” Enhanced IDE) 4.3 billion bytes.
It has only 64MB of RAM but I am planning to buy 128MB RAM for it.

I could connect to the Internet with it by using the single USB port it has.
When a Debian GNU/Linux system was running on this laptop I had used an USB Ethernet adapter for the Internet connection.
This hardware uses the pegasus kernel module.

Edited:

If I do
Code:
modprobe pegasus
nothing happen.

In the /etc/network/interfaces file I have these lines:
Code:
auto lo
iface lo inet loopback

iface eth1 inet dhcp
allow-hotplug eth1

In the /etc/udev/rules.d/70-persistent-net.rules I have this line:
Code:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME=="eth1"

When I do
Code:
/etc/init.d/networking start

I get:
Setting up IP spoofing protection: rp_filter.
Configuring network interfaces... done.

But
Code:
ifconfig -a
gives only the loopback interface, namely lo.

Why I can't create the eth1 interface?
How can I setup this adapter on DSL?

Best, Paul
« Last Edit: December 22, 2018, 02:53:47 PM by csanyipal » Logged

Best, Paul
CNK
Sr. Member
****
Posts: 269


View Profile
« Reply #1 on: December 23, 2018, 09:22:49 PM »

The first thing to check, if you haven't already, is to make sure that the USB support is working. Laptops use more varied chipsets than desktops and incompatibilities with things like USB are more likely. The simplest way of doing this is to run "lsusb -v | less" and look for a description that suggests that it is your USB Ethernet adapter. If you get that, then the USB drivers are most likely working fine.

The pegasus.o module is included in DSL (/lib/modules/2.4.31/kernel/drivers/usb/pegasus.o), but if you can plug the USB-Ethernet adapter into another Linux PC with a distro where it works, you could run "lsmod" and see whether it indicates that other modules are also required for it to work. I found that was the case with some PCMCIA WiFi cards on another Linux distro, more than one module had to be explicitly loaded.

In case you're having no luck at all, there were also PCMCIA ethernet adapters which should be more reliable with DSL.
Logged
csanyipal
Newbie
*
Posts: 2

Mr. Paul


View Profile Email
« Reply #2 on: December 24, 2018, 07:47:03 AM »

The first thing to check, if you haven't already, is to make sure that the USB support is working. Laptops use more varied chipsets than desktops and incompatibilities with things like USB are more likely. The simplest way of doing this is to run "lsusb -v | less" and look for a description that suggests that it is your USB Ethernet adapter. If you get that, then the USB drivers are most likely working fine.

The pegasus.o module is included in DSL (/lib/modules/2.4.31/kernel/drivers/usb/pegasus.o), but if you can plug the USB-Ethernet adapter into another Linux PC with a distro where it works, you could run "lsmod" and see whether it indicates that other modules are also required for it to work. I found that was the case with some PCMCIA WiFi cards on another Linux distro, more than one module had to be explicitly loaded.
In DSL on this old laptop I can use USB pendrive to mount it, so the USB drivers are working fine.
Since I open this thread here, I installed a Debian Sarge on this old laptop, and it can uses the USB Ethernet adapter.
When I run on Debian Sarge
Code:
lsmod
I get this line among others:
Quote
pegasus    22152  0
usbcore   104164  4    ohci_hcd,pegasus
I admit, since I installed Debian Sarge on this old laptop, I do not have installed on it DSL, although I created - during Debian installation - a 60 MB ext2 partition for DSL frugal installation.
I am a fraid to install DSL now because it will change the Grub MBR out there.
Can I avoid that, namely, can I install DSL so so I skip the grub installation when doing DSL frugal install?
And after I have installed DSL, can I just run in Debian Sarge the grub-install so it detect DSL too?
Logged

Best, Paul
CNK
Sr. Member
****
Posts: 269


View Profile
« Reply #3 on: December 24, 2018, 09:10:36 PM »

Looking at the install script, it does skip installing Grub if you choose not to format the target partition, though I don't know if it skips other important steps as well because it says it's then doing an "upgrade". I don't think so...

It doesn't really matter if you reinstall Grub as both distros will be designed to use Grub legacy so you should just have to modify the /boot/grub/menu.lst to add an option for either DSL or Debian depending on which is already there. For more recent distros that use Grub 2, I've had success "chainloading" Grub 2 from Grub legacy, but that shouldn't be required in your case.

Running grub-install from Debian after DSL is installed won't help set it up. You need to edit the menu.lst file to add the option for booting DSL  (http://damnsmalllinux.org/wiki/installing_grub.html).

DSL seems to have ehci-hcd.o instead of ohci_hcd. Check that all of usbcore, ohci_hcd, and pegasus are listed by lsmod when you have DSL running again and the Ethernet adapter plugged in.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Mercury design by Bloc