Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
Did you miss your activation email?
April 25, 2014, 12:39:33 AM

Login with username, password and session length
News
The new DSL forums are now open.
Stats
1249 Posts in 245 Topics by 256 Members
Latest Member: ckrnmcig79
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  Damn Small Linux
| |-+  Other Help Topics
| | |-+  A problem with two KNOPPIX images on the HD
« previous next »
Pages: [1] Print
Author Topic: A problem with two KNOPPIX images on the HD  (Read 1727 times)
davec60
Newbie
*
Posts: 8


View Profile Email
« on: August 25, 2012, 10:08:28 AM »

Hi,
At the moment I have both DSL and Feather fully installed on my HD.
DSL is on sda7 and Feather is on sda 10.
Both use a Knoppix boot image.
When I try booting into Feather on 10 the Grub4dos bootloader picks up the first Knoppix image from DSL on sda7 and I end up with a DSL desktop on sda10 (which obviously doesn't function too well).
The same situation arises in reverse if Feather is earlier on the HD than the DSL partition.
Is there a kernel parameter that I can use in DSL and/or Feather to ensure that the correct Knoppix image is loaded from the correct partition instead of just the first Knoppix image that the bootloader can find?
Thanks,
davec60
Logged
CNK
Full Member
***
Posts: 132


View Profile
« Reply #1 on: August 26, 2012, 01:09:30 AM »

I'm not familiar with Grub4Dos, however as it seems to use ordinary menu.lst commands for configuration, I would suggest that using the "root" command might solve your problem. This tells Grub which partition to operate from, otherwise it seems to guess the partition itself.

Try inserting "root (hd0,9)" (Grub counts from zero) as the first line under the title of the Feather Linux boot option in your menu.lst. Or if you can do temporary modifications to boot options at the Grub4Dos boot menu, edit it there for a quicker test.

eg.
Code:
title Feather Linux
root (hd0,9)
kernel /boot/linux24 root=/dev/hda10 <Options>
makeactive
boot
Logged
kswoodsman
Newbie
*
Posts: 8


View Profile
« Reply #2 on: September 07, 2012, 11:40:19 PM »

It isn't the boot loader that is finding the 'wrong' knoppix image it is /linuxrc in the initrd file loaded with the kernel at boottime.

I have this issue too. Both of mine are in the KNOPPIX directory on a partittion. One now named FEATHER the other named DSL with a simlink pointing to the one I want to boot to on next boot. I have to remember to pull out any thumb drives that might contain an image also since /dev/sd* is checked befor dev/hd*.

I use LILO not GRUB and have the append="BOOT_IMAGE=FEATHER" and append="BOOT_IMAGE=DSL"  and still have this issue. I just change the simlink before rebooting.

If I get to bothered by the problem I will fix it in both my respective minirt24.gz images and post the results/steps taken.
Logged
kswoodsman
Newbie
*
Posts: 8


View Profile
« Reply #3 on: September 08, 2012, 12:42:41 AM »

I found it for my feather install, I i have no idea yet if the same naming is used for dsl.
I gunzipped the feather minirt24.gz image, created an initrd directory , mounted the image there and opened the linuxrc file with a text editor (vim). searched down till I found
KNOPPIX_NAME="KNOPPIX"
the following line explained it all.  The linuxrc script is reading the kernels /proc/cmdline to see if the cloop image of the system files have been renamed or a specific name should be used in place of the default KNOPPIX.

Adding the phrase "knoppix_name=FEATHER" and "knoppix_name=DSL" to the respective append lines in my lilo.conf file before running lilo (again for the 300th time) will hopefully cure this issue for me.
 I'm getting ready to reboot and will post back , soon, if all goes well. If not I'll fix it from one of the other boot images on the harddive Smiley


It worked like a champ ! it rebooted back into dsl with my /KNOPPIX/KNOPPIX simlink pointing to /KNOPPIX/FEATHER.

I hope someone gets some good out of this . I certainly will.
« Last Edit: September 08, 2012, 01:00:08 AM by kswoodsman » Logged
kswoodsman
Newbie
*
Posts: 8


View Profile
« Reply #4 on: September 09, 2012, 01:50:39 AM »

Something that didn't come to mind during my previous responce was the use of appending where linuxrc in the initrd file should look for your KNOPPIX image. Adding "fromhd=/dev/sda7 to the DSL boot section and "fromhdd=/dev/sda10" to the append line of the Feather boot section should cure the problem you were having. Notice that Feather uses "fromhdd=/dev/xxx" and DSL uses "fromhd=/dev/xxx", with xxx being the device and partition.

My problem was more to the tune of both of them being in the same folder on a primary partittion.


Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines
Mercury design by Bloc