Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
March 23, 2023, 02:07:23 PM

Login with username, password and session length
The new DSL forums are now open.
11609 Posts in 311 Topics by 291 Members
Latest Member: mik3ca
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  Damn Small Linux
| |-+  User Feedback
| | |-+  Brother Printer Drivers with DSL (MFC-7340)
« previous next »
Pages: [1] Print
Author Topic: Brother Printer Drivers with DSL (MFC-7340)  (Read 7963 times)
Sr. Member
Posts: 269

View Profile
« on: August 02, 2015, 03:43:01 AM »

Just for the benefit on anyone wondering which path to take in a similar circumstance, here are some notes from today's attempt to get my Brother MFC-7340 printer working in DSL. It only took me an hour, that's pretty good for setting new things up with DSL. Note that this method does not use CUPS, I haven't tried using CUPS in DSL, though it is available from the MyDSL Repository.

The instructions here on the Brother website (http://support.brother.com/g/s/id/linux/en/instruction_prn3.html?c=us_ot&lang=en&comple=on&redirect=on) do actually work for DSL (once you eventually find them...).

The one exception is that dpkg has to be run as root, and the /var/spool/lpd/MFC7340 (the name of the last directory will depend on your printer model) ends up being created without user permissions. This means that when you try to print, lpr will come back with something like:
MFC7340@box: printer 'mfc7340', chdir to '/var/spool/lpd/MFC7340' failed 'Permission denied'
The same error is also generated when the "lpc status" command is tried, which normally shows you the status of configured printers.

To fix, simply use chmod to make the directory for your printer open to all users (as root):
chmod a+rwx /var/spool/lpd/MFC7340

And don't choose this moment to forget that folders need to be marked executable, like I did at first!

Now printing should work from all applications, and directly from the command line for text files with "lpr":
lpr mytesttext.txt

One note about the MFC-7340 Driver (V. 2.0.2-1, 25/06/2008, http://support.brother.com/g/b/downloadlist.aspx?c=au&lang=en&prod=mfc7340_us_as&os=128):
I've found that on some long or complex files, the printer seems to stall on a page and coat the rest of that page with random vertical lines, before continually spitting out blank pages until the print job is canceled at the printer. This also happens in Knoppix 7.2 (on the same PC) where I have the same driver installed via CUPS, so I expect it is a driver problem. In any case it happens quite rarely. I couldn't find any alternative drivers that worked when setting it up in Knoppix.

After this problem occurs, I've found all print jobs are printed blank until the printer is reset (turned off and on).
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Mercury design by Bloc