Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
Did you miss your activation email?
October 01, 2014, 04:16:08 AM

Login with username, password and session length
News
The new DSL forums are now open.
Stats
297732 Posts in 294152 Topics by 245 Members
Latest Member: bdkgkucpvazg
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  Damn Small Linux
| |-+  HD Install
| | |-+  DSL frugal install fun
« previous next »
Pages: [1] Print
Author Topic: DSL frugal install fun  (Read 528 times)
linuxMigrant
Newbie
*
Posts: 1


View Profile
« on: April 12, 2014, 02:45:04 AM »

In trying to [frugal] install DSL (i have been playing around with it for a bit on live cd/usb prior, and knew how to use it), I had some fun to say the least.
I deleted the ubuntu partitions on my hard drive, in order to free up space for DSL (I had forgotten the password anyways, and dsl was more appropriate for the computer -- an old Dell dimension with 1GB ram, 1.6 GHz pentium 4 with WinXP as the main OS).
Of course I deleted grub 2 along with the Ubuntu install.
I found myself on the wiki page about installing grub (once I had formatted the drives and installed DSL, grub wouldn't work, even though it was installed during the frugal install.) So then I had to hunt down the Grub legacy iso, boot through the grub command line, and try to install grub again in terminal.
ERROR: "/dev/cloop has no BIOS device name!"

Some more digging around, and following a link off the wiki page (http://www.damnsmalllinux.org/wiki/installing_grub.html) got me to a very good tutorial in the old static forums 'tips and tricks' (I had seen it before and referenced it a little, but now had to go in-depth with it).
On the second page (http://www.damnsmalllinux.org/f/topic-3-26-8732-5.html), I found almost my exact scenario with a lovely explanation of how to successfully install Grub. And I miraculously got it working (and then re-added windows xp to the menu.lst)

Lo! and behold, DSL finally works. (I forgot to mention lots of googling "fixing grub", and similar search terms, but the ubuntu forums were all that popped up).

So I guess this is a Thank You for keeping those old forums around, and for a very good operating system (once it gets working...)
Logged
CNK
Full Member
***
Posts: 148


View Profile
« Reply #1 on: April 12, 2014, 10:35:41 PM »

Well done!

The Grub manual (http://www.gnu.org/software/grub/manual/legacy) is also a very good reference in case of trouble.

Also, as GRUB is not specific to any OSs, the posts in the Ubuntu forum may have been relevent, as long as they were old enough to be talking about the original GRUB (now known as GRUB Legacy), not the newer GRUB2.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.19 | SMF © 2013, Simple Machines
Mercury design by Bloc