Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
Did you miss your activation email?
August 26, 2016, 12:01:49 PM

Login with username, password and session length
News
The new DSL forums are now open.
Stats
301213 Posts in 295884 Topics by 307 Members
Latest Member: wolfgangw
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  Damn Small Linux
| |-+  HD Install
| | |-+  DSL frugal install fun
« previous next »
Pages: [1] Print
Author Topic: DSL frugal install fun  (Read 3392 times)
linuxMigrant
Newbie
*
Posts: 1


View Profile
« on: April 12, 2014, 02:45:04 AM »

In trying to [frugal] install DSL (i have been playing around with it for a bit on live cd/usb prior, and knew how to use it), I had some fun to say the least.
I deleted the ubuntu partitions on my hard drive, in order to free up space for DSL (I had forgotten the password anyways, and dsl was more appropriate for the computer -- an old Dell dimension with 1GB ram, 1.6 GHz pentium 4 with WinXP as the main OS).
Of course I deleted grub 2 along with the Ubuntu install.
I found myself on the wiki page about installing grub (once I had formatted the drives and installed DSL, grub wouldn't work, even though it was installed during the frugal install.) So then I had to hunt down the Grub legacy iso, boot through the grub command line, and try to install grub again in terminal.
ERROR: "/dev/cloop has no BIOS device name!"

Some more digging around, and following a link off the wiki page (http://www.damnsmalllinux.org/wiki/installing_grub.html) got me to a very good tutorial in the old static forums 'tips and tricks' (I had seen it before and referenced it a little, but now had to go in-depth with it).
On the second page (http://www.damnsmalllinux.org/f/topic-3-26-8732-5.html), I found almost my exact scenario with a lovely explanation of how to successfully install Grub. And I miraculously got it working (and then re-added windows xp to the menu.lst)

Lo! and behold, DSL finally works. (I forgot to mention lots of googling "fixing grub", and similar search terms, but the ubuntu forums were all that popped up).

So I guess this is a Thank You for keeping those old forums around, and for a very good operating system (once it gets working...)
Logged
CNK
Full Member
***
Posts: 207


View Profile
« Reply #1 on: April 12, 2014, 10:35:41 PM »

Well done!

The Grub manual (http://www.gnu.org/software/grub/manual/legacy) is also a very good reference in case of trouble.

Also, as GRUB is not specific to any OSs, the posts in the Ubuntu forum may have been relevent, as long as they were old enough to be talking about the original GRUB (now known as GRUB Legacy), not the newer GRUB2.
Logged
jharris1993
Newbie
*
Posts: 16


View Profile
« Reply #2 on: December 31, 2015, 02:30:03 AM »

I had run into much the same problem - and I spent much time pounding my head on my basement's cement floor trying to fix it - until I *FINALLY* figured out what the problem was:

The error message "ERROR: "/dev/cloop has no BIOS device name!" " translated from OS gibberish to human readable English is "The drive you're trying to install Grub on is not directly connected to the computer's motherboard somewhere.  Perhaps it's connected via a USB cable?"

I found the best way to get Grub to install was to take a computer and connect the hard drive directly to the computer's motherboard via either a direct IDE or SATA connection to the MoBo's (<-- geek-speak for "Motherboard"), internal connectors.  eSATA, FireWire, USB, etc. won't cut it since (in most cases) the device was not recognized as a bootable device at startup.

I did everything possible to "fix" Grub: Voodo, burning brown rice, sacrificing small rodents, threatening it with my gigantic wood-splitting maul, and so forth.  All to no avail.  It was only after I got a clue about what the error actually ment, and hooked the drive directly to the motherboard, that I had any success at all installing DSL on a hard drive.

Hope this helps someone.

Jim (JR)
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Mercury design by Bloc