Damn Small Linux (DSL) Forums
Welcome, Guest. Please login or register.
Did you miss your activation email?
October 01, 2016, 07:06:19 AM

Login with username, password and session length
News
The new DSL forums are now open.
Stats
301220 Posts in 294217 Topics by 279 Members
Latest Member: tazkmo
Search:     Advanced search
* Home Help Search Login Register
Get The Official Damn Small Linux Book. Great VPS hosting provided by Tektonic

+  Damn Small Linux (DSL) Forums
|-+  Damn Small Linux
| |-+  Other Help Topics
| | |-+  libreoffice base?
« previous next »
Pages: [1] Print
Author Topic: libreoffice base?  (Read 3612 times)
Sxs6vHg9Qzdm
Newbie
*
Posts: 2


View Profile
« on: September 05, 2016, 05:33:41 PM »

Is is possible to install libreoffice (base) on DSL?
Thanks!

Just found that openoffice is provided as a myDSL Application Extension (http://distro.ibiblio.org/damnsmall/mydsl/apps/) but totally outdated: version 1.1.4 from 03/11/2005 and 1.1 from 12/03/2004

How can I install openoffice or libreoffice myself?
« Last Edit: September 05, 2016, 05:50:52 PM by Sxs6vHg9Qzdm » Logged
CNK
Full Member
***
Posts: 209


View Profile
« Reply #1 on: September 05, 2016, 10:15:58 PM »

Unfortunately the system requirements page (https://www.libreoffice.org/get-help/system-requirements/#Linux) specifies that it requires Linux kernel 2.6.18 or higher. DSL uses the 2.4.31 kernel, and I believe DSL-N uses 2.6.11. This means that you probably won't be able to get the latest LibreOffice to compile on any version of DSL (unless you upgrade the kernel, which is a major project).

Apache OpenOffice 4.1 requires kernel 2.6 (http://www.openoffice.org/dev_docs/source/sys_reqs.html), so won't work with DSL but should with DSL-N. Version 3.3 is the last that will work with the 2.4.31 kernel in DSL (you will need to use 3.2 though if you don't want to compile glibc yourself, as 3.3 isn't compatible with the glibc libraries in the MyDSL respository (eg. compile.uci)).

I'll leave you to find out which, if any, past versions of LibreOffice are compatible with DSL. I vaguely remember checking myself using the release notes and finding that none supported the 2.4 kernel, but I may be mistaken.
Logged
Sxs6vHg9Qzdm
Newbie
*
Posts: 2


View Profile
« Reply #2 on: September 06, 2016, 08:12:33 AM »

Thank you for the detailed and fast answer!
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines
Mercury design by Bloc