Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: debian compatible, deb packages not working< Next Oldest | Next Newest >
jamessp007 Offline

Group: Members
Posts: 1
Joined: April 2005
Posted: April 15 2005,18:54 QUOTE

I have some deb  packages that are not working .  I have also heard that dsl is not completely debian campatible, rather only debian like.   can anyone confirm this for me?  anyone know another distro that is dsl-like, using fluxbox or xfce,  that is 100% debian compatible?
Back to top
Profile PM 
clivesay Offline

Group: Guests
Posts: 935
Joined: Dec. 2003
Posted: April 15 2005,20:11 QUOTE

You're being too vague.

DSL uses the debian apt-get system to install packages. What app are you trying to install? Are you using apt-get or installing individual .deb packages?

Details please.  :D

Back to top
Profile PM MSN YIM 
cbagger01 Offline

Group: Members
Posts: 4264
Joined: Oct. 2003
Posted: April 15 2005,22:12 QUOTE

The only thing that is 100% debian compatible is called "Debian".

Knoppix has a hard drive install script that will get you close enough to a pure Debian installation.  Just don't call it Debian.  It's a Knoppix HD install.
Back to top
Profile PM 
mikshaw Offline

Group: Members
Posts: 4856
Joined: July 2004
Posted: April 15 2005,23:38 QUOTE

When you say they're not working, do you mean the applications install but don't run, or do they not install?
DSL uses Busybox as a replacement for GNU utils.  Most of the tools found in Busybox are identical in their basic operation, but lack many additional options found in the original tools.  In some cases this is enough to cause failures in some programs.  Try the gnu-utils.dsl extension in a liveCD system and see if your programs will run properly with that.

Back to top
Profile PM WEB 
reidar Offline

Group: Members
Posts: 92
Joined: Sep. 2004
Posted: April 16 2005,10:25 QUOTE

If you want a distro that is 100% Debian compatible, using fluxbox and/or xfce, you should install debian, the base system (no desktop environment at all), then apt-get install x-window-system and apt-get install fluxbox/xfce and all the other apps you need. I have done it myself and it works great. It is not DSL of course, but it is still quite good :-)


P.S. (if you install mdetect and read-edid before you install x-window-system (which is a meta-package), you will have some automatic hardware detection that works fine. At least it did for me.)
Back to top
Profile PM 
4 replies since April 15 2005,18:54 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Quick Reply: debian compatible

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code