Damn Small Linux Forums

Full Version: Asus Eee PC 1001PX starts X only in safe video mode; Ventoy works
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi! It has been a long time, DSL. :-)

I have just tried the current alpha (MD5 c9941fab32e9a6d1962a8119b85a8e85) on my old netbook, an Asus Eee PC 1001PX. It's a model from 2010. It has an x86-64 CPU, 1 GiB of RAM, Intel GMA 3150, and a 1024×600 screen. I have recently installed Debian 12 on it (64-bit), where everything seems to work.

The test went like this. I booted off the USB drive and chose to boot the DSL ISO in Ventoy's normal mode. In DSL's boot menu I also chose the default option. When the system got to graphics, it became stuck in a loop restarting Xorg. Xorg started, stopped with a fatal server error (see the attached log), then started again. I rebooted DSL in safe video mode, and Xorg worked.

Here is a screenshot. 800×600 was the only resolution available in ARandR.

[Image: dsl-2024.alpha-800x600.1706911590.png]

I connected to Wi-Fi without issue and was able to use a USB keyboard and the built-in SD card reader. It seemed like everything but video worked normally. A pretty good start.

I have attached my Xorg.0.log from when DSL got stuck in an Xorg restart loop. (I like that this forum runs MyBB instead of phpBB or SMF.)
Yes, it has been a long time! Thank you for posting with all the details and including the log.
You're welcome! I am glad to help.
Quote:[  175.234] (WW) glamor requires at least 128 instructions (64 reported)
[  175.235] (EE) modeset(0): Failed to initialize glamor at ScreenInit() time.
I think this is the source of the problem. Glamor is a generic accelerated X11 driver, but the GPU in the EeePC does not fulfill the requirements to run it. The legacy Xorg intel video driver, xserver-xorg-video-intel, might work. Alternatively, you can try to use the fbdev driver, by passing xorg=fbdev instead of xorg=safe – like vesa it's not accelerated, but it gave the proper resolution at least on my machine.
Thanks! Passing
to the kernel gave me the right resolution.

[Image: dsl-2024.alpha-1024x600.1706983335.png]
Similar Install issues with Hp mini PC (https://www.manua.ls/hp/mini-110/specifications)
2GB M and 250 SDD

The system repeatedly try to restart and the same or similar log as above.
installing with the safe video works but there is a malform screen for about 30 seconds with part of the Xorg log displayed
it then goes blank boots correctly.
(02-03-2024, 06:19 PM)dbohdan Wrote: [ -> ]Thanks! Passing
to the kernel gave me the right resolution.

[Image: dsl-2024.alpha-1024x600.1706983335.png]

Where i have to set this option? grub.conf?
(02-13-2024, 07:29 PM)mrnicetux Wrote: [ -> ]Where i have to set this option? grub.conf?

I'm new here so I'm not sure but you can probably set this in your xorg.conf device section for your GPU.
I can confirm I experience this too on default settings on an eeepc 701.

Starting in safe mode works - as does setting xorg=fbdev but only on the livecd splash screen. When I tried to set xorg=fbdev within xorg.conf I got into the same xorg crash / reboot cycle. I ended up reinstalling the OS entirely. On reinstall - I set xorg=fbdev when opening the livecd, that setting seemed to have persisted as I am getting the full 800x480 resolution
John, could you add xserver-xorg-video-intel to the ISO? It gives me native 1024x600 resolution on the 1001PX in Debian 12 and DSL 2024 RC2. There is at least one other user with a 1001PX on this forum and more with Intel hardware supported by the driver.
Pages: 1 2