Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RDP into DSL from Win 10
I run a Debian 12 PC and was able to set up RDP following this procedure Debian RDP

Is there a similar procedure to set up RDP for DSL?
(06-07-2024, 07:02 PM)sctn4elk Wrote: I run a Debian 12 PC and was able to set up RDP following this procedure Debian RDP

Is there a similar procedure to set up RDP for DSL?

I don't know what the current state of affairs these days is, but it used to be very simple to just use SSH and X-Tunneling with a local X server on the Windows side. Any graphical application you could execute from the command line would then be rendered on your side and the mouse and keyboard input fowarded. --- Not quite a true remote desktop, but more than adequate.

Otherwise you have to setup a local VNC/RDP server on the Linux side and the client has to be compatible with it. I don't know of any guides to doing that on DSL.
DSL is based on AntiX, which is based on Debian, so it should work.

However, instead of sudo systemctl status xrdp, do sudo service xrdp status, and instead of sudo systemctl restart xrdp, do sudo service xrdp restart.
It looks like xrdp installs fine and the service is up and running.

xfce4 fails to install with a dependency conflict on libpulse0

xfce4-goodies installs fine

firewalld fails to install with a dependency conflict on polkitd , policykit-1
So xrdp works well without the rest? That's good to know.
(06-09-2024, 04:51 PM)Yan Wrote: So xrdp works well without the rest? That's good to know.

Since ufw is installed I opened a port with that and skipped firewalld.

Windows 10 Remote Desktop connected to the DSL instance, but since I don't have xfce4 installed (or any gui other than the DSL base), its just a blank screen.

I'm currently trying to find out on antix about xrdp connection and found this link: ANTIX Forum Post
Try the solution mentioned here (first post), then try to install xfce4 again.
Yes, I found that post when I was looking for openssh installation issues. I tried it, but the key says its the latest one at 20019.3.14 even though that thread has folks showing 20019.5.0 as the key.
OK, tried a different approach:

sudo apt update --allow-insecure-repositories
sudo apt upgrade --allow-unauthenticated

This picked up the new keyring and allowed a whole bunch of stored dependencies to be loaded. After which I did:

sudo apt install xfce4

This completed successfully and using F1 at DSL reboot, I was able to load the xfce4 desktop which appears to be working normally. (UPDATE: well actually a small window pops up and indicates that xfce4 is not a supported window manager and it gives you a list of the available WM's installed. If I just select xfce4 it appears as though all of the functionality is there so far.)

I went back over the steps from the Debian link I originally posted and made sure the set up was correct. I opted not to install firewalld and just configured ufw accordingly.

However, when I use RDP from my Win 10 machine the connection is made, but it is still using the Xorg session and appears like the Antix forum post. So it looks like xrdp is not launching the xfce4 desktop for the RDP connection as it should. Maybe there is a xrdp log or something that would indicate what the issue is?

OK, the Antix post offered a few things to try and so I did:

First I installed xorgxrdp but there was no change in the Windows RDP behavior, still connects but just shows a blue screen.

Second I tried various flavors of the xrdp.ini file updates:
startxfce4 - does not work, just shows the blue screen after connection
/usr/local/bin/desktop-session xfce4 - xrdp server fails to start when restarted
exec /usr/local/bin/desktop-session xfce4 - xrdp server starts, but no change in RDP behavior
startzzz-jwm - RDP connects, but after a few seconds the whole session dies and closes

I guess I can try the other suggestion of adding this to my start (although I'm not sure how to implement it):
zzzfm --desktop &

I can also try using "startblah" and "/usr/local/bin/desktop-session blah" with all of the other available WM's in DSL?

If I can't get Windows RDP working I guess I can try:
Secure Shell (SSH) protocol coupled with X11 forwarding.
Might be worth checking out this page:

It gives a very brief overview of installing the packages (the Arch ones) and covers some basic troubleshooting.

In this case, the section titled 3.5 Non-Root user may be relevant since it says that some RDP clients may launch with an empty/blank screen if certain options aren't set in Xwrapper.config.


I have found that the arch linux wiki often contains useful information even if the entire article isn't relevant to my specific situation.

Forum Jump:

Users browsing this thread: 1 Guest(s)