Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Comments on RC3
I've tried it on my Acer Aspire One 522, so a real system, not virtualisation.

You've updated all the packages; thanks.

Locale en_CA is supposed to be included on the ISO, but it isn't.

On the first boot screen, pressing F3 brings up a list of cities to choose the time zone. Some cities have an asterisk after their name, but others don't. What's the difference?

The installer marks a swap partition as file system type 83 rather than the correct 82.

In the Control Centre (thanks for the correct spelling, BTW [Image: wink.png]), under Network, when choosing Select Wifi Application, I can't choose Connman: the mouse jumps back to Ceni. However, the button marked Wifi Connect starts Connman anyway, and the button under that starts Ceni, so perhaps Select Wifi Application is unnecessary anyway.

When I installed firefox-esr, it appeared in the Applications menu, but frozen-bubble and libreoffice-writer didn't.

I get the following error message after using apt install, but the installation succeeds anyway. This bug seems to originate with AntiX, so you might want to forward it to them:

(desktop-menu:8512): Gtk-CRITICAL **: 17:24:22.083: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
Writing Menu: jwm
Traceback (most recent call last):
  File "/usr/local/bin/desktop-menu", line 477, in <module>
  File "/usr/local/bin/desktop-menu", line 313, in build_menu
  File "/usr/local/bin/desktop-menu", line 219, in process_menu
    icon = find_icon(entry) or default_folder_icon
  File "/usr/local/bin/desktop-menu", line 148, in find_icon
    if icon_theme.lookup_icon(appicon, icon_size, 0) and not no_gtk:
AttributeError: 'NoneType' object has no attribute 'lookup_icon'

Edit: Enhancement request: show the battery status in conky.
Excellent feedback Yan. I really appreciate the details and bug reporting. I'll get en_CA back in the next cut.
Here's a strange one: several commands in the Control Centre won't work unless I do sudo in a terminal first.

If I try to run some commands without running sudo first, I see sudo appear at the top of conky's list of processes, then disappear, and nothing happens. If I run sudo, then the command runs properly. It seems that it can be any command with sudo, even something as trivial as sudo ls. Doing su - doesn't work.

Here are some affected commands:

Maintenance > Network Assistant
System > Set Time & Date
System > Toggle Firewall On/Off
Software > Manage Packages

Presumably the system remembers my password if I run sudo first.

Other commands seem to work whether I do sudo or not, and some don't work at all even if I do sudo. I assume you're still working on the commands that don't work, but if not, I can post a list.
Thanks again Yan! I'll try to track down as many of these bugs as I can. If yo don't mind making a list of the commands that don't work it would be helpful. I am considering dropping en_CA and maybe including German and Spanish in the iso, Germany is the second largest traffic source in my website stats, so I think it might have higher utility than providing en_CA.
Here's how it is on my system. (It's crooked because I couldn't figure out how to make a real table.)

Command                                           Works before sudo   Works after sudo

Desktop - Edit JAM Settings                  N                            N
             - Edit Fluxbox Settings            N                            N
             - Configure Look & Feel           Y                            Y
             - Edit System Monitor             Y                             Y
              - Preferred Applications          Y                            Y
Software - Manage Packages                Y                            Y
System  -  Choose Startup Services       N                            Y
              -  Alternatives Configurator    N                            N
               - System Lang.  Manager      Y                            Y
              - Set System Keyb. Layout     N                            Y
              - Current Keyboard Layout     Y                            Y
              - Set Date & Time                 N                            Y
              - Process Manager                Y                             Y 
Network  - Select Wifi Application         Y                            Y
               - Wifi Connect                    Y                              Y
               - Network Interface             Y                              Y
               - ADSL/PPPOE Config.         Y                              Y
               - Toggle Firewall On/Off       N                              Y
Shares      - Shared Folders                 Y                              Y
Session     - Set Screen Resolution       Y                              Y
                - Password Prompt             Y                              Y
                - Set Grub Boot Image        N                             Y
                - Engage Autoususpend      Y                              Y
                - Login Manager                N                              Y
                - User Desktop-Session      N                              N
                 - Activate Clipb. Manager   Y                              Y
Disks          - Configure Automount     Y                               Y
                 -  Live USB Maker             N                              N
                 -  Image a Partition           Y                               Y
Hardware    - Mouse Configuration      Y                               Y
                  - SCSI Bus Rescan            Y                              Y
                  - Sound Card Chooser       Y                              Y
                  - Test Sound                   Y                                Y
                  - Adjust Mixer                 Y                                Y
                  - Alasamixer Equalizer      Y                                Y
Drivers            N/A (No commands!)
Maintenance  - Network Assistant        N                               Y

I suggest you indicate the actual command for advanced users (e.g. Manage Packages  = synaptic). You sometimes do this, but not always.

I believe locales use very little disk space, is that correct? If so, I'd suggest you include several languages, but only one option for each (i.e., only en_US, de_DE, fr_FR, etc.)
Thanks for doing all that! The interesting thing about the control center is that it's dynamic in how it assigns programs so that it will select from choices under each category (if A then use A, If not look for B, if B use B). So, including the actual program name would take some modification to the code. In the next release I am pointing "Live USB Maker" to the script I wrote for DSL.
>On the first boot screen, pressing F3 brings up a list of cities to choose the time zone. Some cities have an asterisk after their name, but others don't. What's the difference?

Sorry, the asterisk indicates an area that uses Daylight Savings Time.

In the next release I am adding Spanish, French and German language support back as well as Australia and UK keyboard support, en_CA is being dropped for now. I think I have a work around for most of the Control Center bugs.

Forum Jump:

Users browsing this thread: 1 Guest(s)