Talk:Frequently Asked Questions

From DSL Wiki


Down link

Sorry, I couldn't see how to edit the page. The link to dsl-emmbeded download needs to be updated.

System requirements

What is the least possible hardware configuration to run DSL on? Can someone answer this?

Answer: You want the forums I think.

Saving static IP address

It would be more complete to use the lines

ifconfig eth0 broadcast yyy.yyy.yyy.yyy netmask zzz.zzz.zzz.zzz

where XXX.XXX.XXX.XXX is the static IP address to be used, for example yyy.yyy.yyy.yyy is the broadcast address to be used, for example and zzz.zzz.zzz.zzz is the netmask to be used, for example

route add default gw

where is the IP address of the gateway to be used, for example

echo nameserver > /etc/resolv.conf

where is the domain name server to be used, for example, ..........(do you know a good one e.g. googles?)

ifup eth0

starts the network device eth0.

Commands for other devices can follow.


"How can have VNC start automatically at boot" should be "How can I have VNC start automatically at boot".


Might want to change that to Windows to save yourself looking like prejudice idiots. I was interested in trying DSL, but intolerant morons are definitely not my favorite distro-makers. Or if it's just the Wiki-author, give him a beating, and let's be friends ;)

  • I don't know, I chuckled when I read it :P -nFriedly


I'd reccomend adding a link to Installing to a USB Flash Drive in the Frequently Asked Questions#How Do I Install to a USB Pendrive? section

Side note: Why is so much stuff locked from editing?! Isn't that the whole point of a wiki: being user editable!? -nFriedly 4 December 2006 23:02 (EST)

Big Changes

As for the static IP changes, I felt it was clearer as is, so I didn't change it. Some additions/clarifications might be a good idea, but I especially didn't like the idea of writing a paragraph after each simple command.

Fixed the VNC typo.

As for Windows, see How To Use This Wiki, especially the last section, DSL is not Wikipedia.

I deleted the USB content, and replaced it with a link to the full USB page. No sense writing the same thing twice.

I think FAQ was locked because of spam. John is pretty conservative when it comes to letting people touch his stuff. I added Frequently Asked Questions Beta. Now you can make the changes yourself, and I'll bring them over every couple weeks or so.

-Winter Knight, Dec 5 2006

I Suggest You Add Hyperlinks to "How Can I Help Section"

This will improve your chances of people actually helping.

Initial boot problems


I tried my "luck" with DSL, but I couldn't boot it. I burned it to become a bootable CDRW, I tried with all the 3 images, but I get a black screen almost right after trying to boot. I tried the failsafe options and also setting to the VGA mode. It got stuck one step further, at the Starting the kernel step. I'm using a Fujitsu Siemens Amilo L7300 laptop. Any ideas? P.S.: I didn't have any (such big) problems running Fedora, SUSE, Ubuntu, etc... Any help will be warmly welcomed to e-mail:

Hello! I have the same question! How can I find the installation instruction. Waiting for ...

X Windows version?

What version of X does DSL use that`s tiny enough?

JWM and Fluxbox. -Michael

dsl-embeded download malfunction

When I tried to download dsl by going to link it didn't work. It said the link could not be found or something. Does any one know what to do? If so post it here.

Most likely an old link or a broken mirror. Try another mirror. - Curaga

It's an old version. The version in the link is 4.4.6, while the current version (as I type this, anyway) is 4.4.10. The fix is easy (if you don't have access to change this page): just click the link, then (in your address bar) remove everything after "/current/" and press enter (or click Go). You'll end up with a file listing; scroll down until you see dsl-<version number> and click it. Voila, DSL-embedded. Sendoshin 14 March 2009 01:45 (UTC)

386 is NOT enough

I have just tried to run DSL on a 386 following Loadlin Install, and the boot comes to a screeching halt with the following words:

No coprocessor found and no math emulation present.
Giving up.

Please spare other 386 hopefuls the headaches I've been through by appending the requirement for a 387 math coprocessor on the FAQ page. - NeoAmsterdam 2008-03-01 14:03 EST

"Broken links in How can I help?" section.

The link with this title: buy DSL on a BOOTABLE usb pendrive

points to this URL:

when it should point to:

More broken links

"Can I run DSL inside Windows? Yes, Download dsl-embedded. Unzip and Click dsl-base.bat. This will run DSL in the Qemu Virtual Machine. For an overview of Virtual Machines and Running DSL, see this Article"

When clicking "dsl-embedded" it goes to . Maybe it should be ?

How does the CD look like?

There is a CD one can order in the shop. Is there a print on the upper side or is it just a "raw" CD in business card size with the DSL data burnt on it?