Joined: Nov. 2004
||Posted: Nov. 20 2004,16:06
I'm an apt newbie, but a moderately experianced linux user.
I installed DSL from the ibiblio mirrior using the DSL single floppy/web install method. I assume this means that I have a pretty recent copy.
I'm trying to install the perl package so that I can install apache and oddmuse wiki. When I use apt-get install perl, I get the error message
The following packages have unmet dependencies:
perl: depends perl-base (=5.6.1-8.7) but 5.8.0-18 is to be installed
E: broken packages
Does this mean perl wants an older (5.6.1-8.7) version of perl-base to be installed? Or does it mean that the perl-base is 5.6.1-8.7, but perl 5.8.0-18 was going to be installed?
Attempting to uninstall perl-base provokes a long and threatening warning message that includes a mention of perl-base taking LILO with it when it goes. Needless to say, that would be suboptimal.
If anyone can offer a pointer on how to tackle this, I'd appreciate it.