Search Members Help

» Welcome Guest
[ Log In :: Register ]

Mini-ITX Boards Sale, Fanless BareBones Mini-ITX, Bootable 1G DSL USBs, 533MHz Fanless PC <-- SALE $200 each!
Get The Official Damn Small Linux Book. DSL Market , Great VPS hosting provided by Tektonic
Pages: (2) </ [1] 2 >/

[ Track this topic :: Email this topic :: Print this topic ]

reply to topic new topic new poll
Topic: Problem installing perl with apt, perl-base version conflict?< Next Oldest | Next Newest >
Azariel Offline

Group: Members
Posts: 1
Joined: Nov. 2004
Posted: Nov. 20 2004,16:06 QUOTE

I'm an apt newbie, but a moderately experianced linux user.

I installed DSL from the ibiblio mirrior using the DSL single floppy/web install method. I assume this means that I have a pretty recent copy.

I'm trying to install the perl package so that I can install apache and oddmuse wiki. When I use apt-get install perl, I get the error message

The following packages have unmet dependencies:
  perl: depends perl-base (=5.6.1-8.7) but 5.8.0-18 is to be installed
E: broken packages

Does this mean perl wants an older (5.6.1-8.7) version of perl-base to be installed? Or does it mean that the perl-base is 5.6.1-8.7, but perl 5.8.0-18 was going to be installed?

Attempting to uninstall perl-base provokes a long and threatening warning message that includes a mention of perl-base taking LILO with it when it goes. Needless to say, that would be suboptimal.

If anyone can offer a pointer on how to tackle this, I'd appreciate it.
Back to top
Profile PM 
ke4nt1 Offline

Group: Members
Posts: 2329
Joined: Oct. 2003
Posted: Nov. 20 2004,16:40 QUOTE

Did you try using " apt-get install perl perl-base "  ??

It looks like perl thinks it will break, having a perl of 5.8.0 and a
perl-base of 5.6.1..  This command should fill apt dependency needs.

Are you using the "unstable" apt repository in your sources.list?
If not, try that too, as it may well upgrade both when you run
" apt-get install perl "

And since DSL is not "pure" debian, don't be surprised if you
see these types of errors when installing apache and your wiki ..

Back to top
Profile PM 

Posted: Dec. 09 2004,05:14 QUOTE

I'm also trying to get apache installed, I did not have any luck with the apt-get install perl per-base suggestion above... any other ideas?

Thanks in advance.
Back to top
deleric Offline

Group: Members
Posts: 3
Joined: July 2004
Posted: Dec. 30 2004,00:02 QUOTE

Try this:

apt-get -testing install perl-base

It gives me:


root@box:/home/dsl# apt-get -testing install perl    
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
 libdb4.2 libgdbm3 perl-modules
Suggested packages:
The following NEW packages will be installed:
 libdb4.2 libgdbm3 perl perl-modules
0 upgraded, 4 newly installed, 0 to remove and 147 not upgraded.
Need to get 5829kB of archives.
After unpacking 23.3MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 testing/main libdb4.2 4.2.52-17 [388kB]
Get:2 testing/main libgdbm3 1.8.3-2 [21.3kB]                                                
Get:3 testing/main perl-modules 5.8.4-3 [2182kB]                                            
Get:4 testing/main perl 5.8.4-3 [3238kB]                                                    
Fetched 5829kB in 1m31s (63.9kB/s)                                                                                  
Selecting previously deselected package libdb4.2.
(Reading database ... 10808 files and directories currently installed.)
Unpacking libdb4.2 (from .../libdb4.2_4.2.52-17_i386.deb) ...
Selecting previously deselected package libgdbm3.
Unpacking libgdbm3 (from .../libgdbm3_1.8.3-2_i386.deb) ...
Selecting previously deselected package perl-modules.
Unpacking perl-modules (from .../perl-modules_5.8.4-3_all.deb) ...
Selecting previously deselected package perl.
Unpacking perl (from .../archives/perl_5.8.4-3_i386.deb) ...
Setting up libdb4.2 (4.2.52-17) ...
Setting up libgdbm3 (1.8.3-2) ...
Setting up perl-modules (5.8.4-3) ...
Setting up perl (5.8.4-3) ...

Back to top
Profile PM 
Stuart Leask

Posted: Mar. 12 2005,18:39 QUOTE

I have the same problem.

The lickety-slick DSL v1.0

I try apt-get-ting r-base r-base-core and r-recommended, and it tells me
r-base-core: Depends: perl but it is not going to be installed
I add perl, and it tells me :
Depends: perl-base (= 5.6.1-8.7) but 5.8.0-18 is to be installed perl to the list

And the suggestions above don't seem to change this situation...

Help! I can't begin to describe how cool it'll be to stroll around at work doing my analyses on as powerful machine I need, while my colleagues are stuck with their WimxP 'workstations'...
Back to top
7 replies since Nov. 20 2004,16:06 < Next Oldest | Next Newest >

[ Track this topic :: Email this topic :: Print this topic ]

Pages: (2) </ [1] 2 >/
reply to topic new topic new poll
Quick Reply: Problem installing perl with apt

Do you wish to enable your signature for this post?
Do you wish to enable emoticons for this post?
Track this topic
View All Emoticons
View iB Code